Jump to content
truht

Constantly getting Error Request Timed Out

Recommended Posts

If you are still trying to connect to the North American Servers, that may be the error.  Try using a Europe server and see how it goes. The ping may be a little bit more, but it hasn't affected me (100's range) and I have been problem free all afternoon as long as I stay on the European server. 

  • Thanks 1

Share this post


Link to post
Share on other sites

Madily is right, it's usually a server message. Using the settings menu will allow you to pick what server you'd like to play on, EU is a safe bet lately!

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, TermsOfService said:

it's been since launch like this for me...

Have you attempted to change to the EU servers for now? 

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, Madily said:

Have you attempted to change to the EU servers for now? 

I finally managed to get on, but not on the EU servers ironically, EU and Asia don't work for me, only NA, and only after i do this thing where i choose the NA server, then click on Auto Choose Server, then it works with 200+ Ping.

This makes no sense as i live in the UAE, if anything i should be able to access EU or Asia servers but not NA cuz of high ping... (This happened before, it worked for like an hour on launch after trying alot, then after 30 mins - 1 hour it just locked me out for good... until now that is...)

I'm just glad it works... for now... i really hope it keeps working and doesn't lock me out again...

  • Sad 1

Share this post


Link to post
Share on other sites
1 minute ago, TermsOfService said:

I finally managed to get on, but not on the EU servers ironically, EU and Asia don't work for me, only NA, and only after i do this thing where i choose the NA server, then click on Auto Choose Server, then it works with 200+ Ping.

This makes no sense as i live in the UAE, if anything i should be able to access EU or Asia servers but not NA cuz of high ping... (This happened before, it worked for like an hour on launch after trying alot, then after 30 mins - 1 hour it just locked me out for good... until now that is...)

I'm just glad it works... for now... i really hope it keeps working and doesn't lock me out again...

I am so sorry to hear that! I wish that trick would work for now!! Hopefully it won't be long before its fixed ;)

 

  • Haha 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...