Jump to content
truht

Constantly getting Error Request Timed Out

Recommended Posts

Been getting this error when trying to log in for about 12 hours now, not sure if it will fix itself or not.

Share this post


Link to post
Share on other sites

If you are still trying to connect to the North American Servers, that may be the error.  Try using a Europe server and see how it goes. The ping may be a little bit more, but it hasn't affected me (100's range) and I have been problem free all afternoon as long as I stay on the European server. 

  • Thanks 1

Share this post


Link to post
Share on other sites

Madily is right, it's usually a server message. Using the settings menu will allow you to pick what server you'd like to play on, EU is a safe bet lately!

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, TermsOfService said:

it's been since launch like this for me...

Have you attempted to change to the EU servers for now? 

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, Madily said:

Have you attempted to change to the EU servers for now? 

I finally managed to get on, but not on the EU servers ironically, EU and Asia don't work for me, only NA, and only after i do this thing where i choose the NA server, then click on Auto Choose Server, then it works with 200+ Ping.

This makes no sense as i live in the UAE, if anything i should be able to access EU or Asia servers but not NA cuz of high ping... (This happened before, it worked for like an hour on launch after trying alot, then after 30 mins - 1 hour it just locked me out for good... until now that is...)

I'm just glad it works... for now... i really hope it keeps working and doesn't lock me out again...

  • Sad 1

Share this post


Link to post
Share on other sites
1 minute ago, TermsOfService said:

I finally managed to get on, but not on the EU servers ironically, EU and Asia don't work for me, only NA, and only after i do this thing where i choose the NA server, then click on Auto Choose Server, then it works with 200+ Ping.

This makes no sense as i live in the UAE, if anything i should be able to access EU or Asia servers but not NA cuz of high ping... (This happened before, it worked for like an hour on launch after trying alot, then after 30 mins - 1 hour it just locked me out for good... until now that is...)

I'm just glad it works... for now... i really hope it keeps working and doesn't lock me out again...

I am so sorry to hear that! I wish that trick would work for now!! Hopefully it won't be long before its fixed ;)

 

  • Haha 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×