Jump to content
asdf3011

Altars not giving any buffs

Recommended Posts

Sense the current patch, for maybe halve a month ago altars stopped giving me the particles effects and for the most part the buffs also. I can physically use altars, or stand near an altar that is being used by a teammate and I get nothing. The only two altars that do work are the energy and xp altar. As a more late game player this bug does not cause too much harm to me, but does make leveling for example harder as altars give powerful buffs to early game characters. I am not sure if I am the only person with this bug, but I I still want to let you know, as I know as a new player the bug would make dungeons less enjoyable for me. However I am fine if these bug is put on backlog because as far as I know it only seems to effect me, and as a more end game player the bug has a smaller impact on my game. 

Share this post


Link to post
Share on other sites

There has always been some issues with receiving certain buffs from alters.  Sometimes, another party member activates an alter, yet it still seems activatable.  Other times I activate the alter alone and don't appear to get any buffs.  I have heard reports that if you are in an instance and someone activates an alter, everyone SHOULD get the buff regardless of distance, but I don't know if this is actually the case.  I'm not sure if it is an issue with the buff just not appearing and the effects are received, or that the buffs just are not working in general.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×